.net CMS
.net CMS > Web Site Maker > Installazione e avvio dell’applicativo web > Problemi inerenti l’installazione del CMS

Errore applicativo

RSS
Autore
Giorno e Ora
Messaggio Operazioni
Antonio Mulasso
male
amulasso@gmail.com
Mulasso

Ciao sono nuovo, ho provato stamane ad installare sul mio notebook con win7 sp1 l'applicativo netcms. Dopo vaarie peripezie l'ho configurato sulla porta 8530. Ma quando lancio l'applicativo mi dice che il servizio non è disponibile.
Come mai, eppure ho seguito alla lettera il tutorial.

Saluti
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Se lo vuoi installare senza sbattimenti, installalo dalla windows application gallery: http://www.microsoft.com/web/gallery/cmsaspnet.asp... (quella comunque non è la versione aggiornata che invece trovi su sourceforge seguendo il link download su questo sito).
Se invece opti per l'installazione manuale sotto server IIS, ti ho preparanto un video che mostra passo passo come fare: L'unica cosa da fare attenzione è impostare la versione 4.0 del framework per il pool della applicazione.
Antonio Mulasso
male
amulasso@gmail.com
Mulasso

Ciao Andrea, ho seguito passo per passo il tuo tutorial, ma all'avvio ricevo questo errore:
Errore server nell'applicazione '/CMS'.
---
Errore del parser
Descrizione: Errore durante l'analisi di una risorsa necessaria per soddisfare la richiesta. Rivedere i dettagli relativi all'errore e modificare in modo appropriato il file di origine.
Messaggio di errore del parser: Accesso alla directory TEMP negato. L'identità "NT AUTHORITY\SERVIZIO DI RETE" con cui viene eseguito XmlSerializer non dispone di autorizzazioni sufficienti per accedere alla directory TEMP. CodeDom utilizzerà l'account utente utilizzato dal processo per eseguire la compilazione, pertanto se l'utente non ha accesso alla directory TEMP, non sarà possibile eseguire la compilazione. Utilizzare l'API Path.GetTempPath() per individuare la posizione della directory TEMP.
Errore nel codice sorgente:
[Nessuna riga di codice sorgente corrispondente]
File di origine: /CMS/App_WebReferences/com/webservicex/www/ Riga: 1
---
Informazioni di versione: Versione di Microsoft .NET Framework:4.0.30319; Versione di ASP.NET:4.0.30319.272
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Entra in Windows in modalità amministratore e prova se parte.
Per qualche motivo arcano non ti si compila perchè non ha i permessi per accedere alla directory temp:
.NET non mette mai gli eseguibili sotto la cartella della applicazione ma li genera e mantiene in tempo.
Verifica che la tua cartella per i file TEMP sia in locale, molti per velocizzare la spostano in ram (creando un ram disk).
Questo problema non dipende dal CMS, nel tuo caso nessuna applicazione ti si compilerebbe.
Se non ne vieni a una apri un ticket di aiuto su: http://forums.iis.net/1051.aspx
Puoi trovare aiuto anche sulla comunità italiana di Microsoft .NET
Se lo installi da Webmatrix tramite il bottone su questo sito http://www.microsoft.com/web/gallery/cmsaspnet.asp... non ti funiona?
Guido Eugenio
male
jenkaitalii@hotmail.com
Theo

La via più semplice è quella di installare per primo WebMatrix ed i vari programmi del suo menù (esclusi i database che non servono), solamente dopo questo passo istalli il CMS. A me sia con Windows XP home edition sia in Windows 7 Professional non ha dato alcun problema.
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Mulasso:
Errore durante l'analisi di una risorsa necessaria per soddisfare la richiesta.

Ieri ho fatto una prova ad installarlo in locale su IIS 7.5 e Windows 7 (sono rimasto sorpreso che non vi è più l'opzione "importa/esporta pacchetto").
Non vi è stato modo di farlo partire.. sono diventato matto smile_omg, la cosa strana è che ero sullo stesso computer con cui sviluppo e quindi in ambiente di debug con Visual Studio funziona, e anche con Webmatrix - su quella macchina - non ho avuto alcun problema.
Dopo svariati tentativi mi sono arreso, poi questa mattina all'alba vado a reinstallare il framework 4.0 con la procedura di riparazione (basta eseguire questo http://www.microsoft.com/en-us/download/details.as...) e magicamente la web application è partita senza problemi.