.net CMS
.net CMS > Web Site Maker > Installazione e avvio dell’applicativo web > Problemi inerenti l’installazione del CMS

Errore configurazione web.config

RSS
Autore
Giorno e Ora
Messaggio Operazioni
Domenico Pennacchio
notdefinite
cosmoweb@libero.it
Cosmoweb

Ho fatto l'upload del cms e configurato tutto come da guida, però mi si aspe la pagina con errore

Server Error in '/' Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: This configuration section cannot be used at this path. This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file.

Source Error:

Line 80: <identity impersonate="true" userName="Admin" password="admin"/>
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Ok, il file di configurazione è il web.config
Così come distribuito, la linea 80 è differente da quella da te riportata e che appare nella pagina di errore, questo perchè se apporti delle modifiche da pannello (per esempio il plesk), o da IIS, tali modifiche si ripercuotono su questo file.

Puoi provare innanzitutto a vedere se realmente il file web.config sul tuo hosting o server si differisce da quello distribuito con il file zip.
Se così, rimpiazzalo.

Te usi un servizio di hosting o un server dedicato?

In genere su un servizio di hosting dovrebbe funzionare così com’è, copiando l’intero pacchetto via ftp, al massimo devi abilitare in scrittura la directory app_data (di default dovrebbe già esserci sul tuo host questa directory attiva in scrittura).

Se usi un server, allora dai una occhiata qui nella parte intitolata “Dare accesso all’applicativo web per le operazioni di lettura e scrittura alla directory App_Data”: http://it.cmsaspnet.com/?p=47&a=26&t=configurazion...

Presumo che l'errore nel tuo caso sia dovuto a:
La linea 80 dice all'applicativo web di impersonalizzare, ovvero di immedesimarsi, nell’user Admin, avente password admin: Tale user chiaramente deve realmente esistere sulla macchina in cui si sta tentando di far girare il CMS.
Nome e password sono Case Sensitive, ovvero, bisogna far attenzione alla maiuscole e minuscole.
Domenico Pennacchio
notdefinite
cosmoweb@libero.it
Cosmoweb

Adesso ho messo il file originale web.config cosi com'è nel CMS, mi sono assicurato che app_data abbia i permessi di lettura/scrittura e dal pannello di controllo (hosting windows condiviso su aruba) ho modificato la modalità pipeline da classic ad integrated e adesso mi da errore 500, quindi nella linea 80 non devo inserire username e password?
Andrea Bruno
male
customercare@officialguide.info
Webmaster

OK: Gli errori 500 sono errori lato server generici. Andiamo per passi:
Con l'errore 500 appare una descrizione?
Sincerati che sia settata la versione 4.0 di .NET framework.
Testai Aruba nel 2003 e mi ricordo che non ebbi difficoltà ad installarvi il CMS. Ho appena visto sul Knowledge Base di Aruba che la directory app_data è presente già con attivi i permessi di scrittura.
L'errore 500 sotto IIS su server dedicato lo si risolve così: http://it.cmsaspnet.com/?p=51&a=26&t=500internalse... se l'errore è il medesimo (l'errore 500 può dipendere da vari fattori lato server) devi trovare dal pannello di impostazione del servizio hosting, come disabilitare l'Impersonation, oppore agire sul web config:

<configuration>
<system.web>
<identity impersonate="false"/>
</system.web>
</configuration>

Sai modificare il web.config? A te interessa solo la riga "identity".
Se quanto sopra non di risolve l'errore, prova allora ad impostare la direttiva "identity" così:

<identity impersonate="true" userName="XXXsnailaruba.it" password="XXX" />

Chiaramente i valori coperti dalle XXX sono quelli del tuo account e la snail corrisponde a @.
Domenico Pennacchio
notdefinite
cosmoweb@libero.it
Cosmoweb

Con l'errore 500 esce scritto:

Server Error
500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.

La versione è la 4.0 su windows server 2008, aruba mi da anche la possibilità di cambiare la modalità pipeline (classic e integrated).

Modalità integrated: Modificando web.config con il tuo codice mi da errore 500 lo stesso anche inserendo login e password per accedere al sito.

Modalità classic: Modificando web.config con il tuo codice mi da il solito errore alla linea 80 e lo stesso anche inserendo login e password per accedere al sito.
Domenico Pennacchio
notdefinite
cosmoweb@libero.it
Cosmoweb

adesso appare il CMS, ho modificato così:

<system.web>
<customErrors mode="Off"/>
</system.web>


adesso come posso entrare come amministratore?
Guido Eugenio
male
jenkaitalii@hotmail.com
Theo

Cito dalla guida che puoi leggere nella sidebar a sinistra.. Ci sono voci per ogni cosa sia necessaria; questa parte si trova in "Da dove incominciare" : "Installazione":::
"..Al primo avvio verrà creato un utente dal nome "Admin" e password "admin", questo utente dispone di tutti i privilegi di amministrazione e supervisione della applicazione web installata. Per procedere alla configurazione del vostro sito, accedete quindi via http (da browser) alla url corrispondente al vostro sito web, a questo punto entrate usando il nome utente "Admin" e password "admin" (per questioni di sicurezza si consiglia di cambiare la password al primo accesso!).
http://it.cmsaspnet.com/?p=3&a=26&t=installazione
Domenico Pennacchio
notdefinite
cosmoweb@libero.it
Cosmoweb

Questo è il dominio dove sto provando: http: / / win . ballanapoli . it

con Admin e admin mi da errore, forse perché l'ho omesso nel file web.config?

Perché ho lasciato solo così:

<system.web>
<customErrors mode="Off"/>
</system.web>


Se metto l'identity impersonate e tutto il resto mi da errore:

Server Error in '/' Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: This configuration section cannot be used at this path. This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file.

Source Error:

Line 78: <connectionStrings/>
Line 79: <system.web>
Line 80: <identity impersonate="true" userName="Admin" password="admin"/>
Line 81: <httpRuntime requestValidationMode="2.0" executionTimeout="120" maxRequestLength="4096" useFullyQualifiedRedirectUrl="false" minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100"/>
Line 82: <trace enabled="true" requestLimit="10" pageOutput="false" traceMode="SortByTime" localOnly="false"/>


Source File: d:\inetpub\webs\ballanapoliit\web.config Line: 80

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
Guido Eugenio
male
jenkaitalii@hotmail.com
Theo

Allora prova semplicemente registrando un nuovo utente; se ricordo bene dovrebbe essere che il primo utente che viene iscritto dall'apposita pagina di accesso al Sito diviene automaticamente "Supervisor" del Portale e di tutto il NetWork (questo nel caso punterai altri domini al CMS), ovvero colui che detiene il livello più elevato degli utenti.
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Vai su Sign-in e da lì, su "Get a new user account". Registri quindi il tuo primo utente che sarà il "supervisor", ovvero l'user con il ruolo più importante.