.net CMS
.net CMS > Web Site Maker > Installazione e avvio dell’applicativo web > Problemi inerenti l’installazione del CMS

newbie con problemi di istallazione

RSS
Autore
Giorno e Ora
Messaggio Operazioni
Martina Cadmio
notdefinite
romoletta1st@alice.it
Maze

ciao a tutti, ho da poco a che fare con siti dinamici, fin ora ho costruito solo siti di presentazione che qindi non richiedevano db e quant'altro. ho comprato un dominio su aruba con host win e mysql. come da istruioni scarico il file cms.zip, lo estraggo e copio il contenuto nel root del mio sito con flezilla.
l'errore che mi da quando mi collego al sito per la configurazione è:

Server Error in '/' Application.
Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

Source Error:

Line 93: Set explicit="true" to force declaration of all variables.
Line 94: -->
Line 95: <compilation debug="false" strict="false" explicit="true" targetFramework="4.0">
Line 96: <compilers>
Line 97: <compiler type=".NET Type" compilerOptions="/optimize+"/>


Source File: D:\Inetpub\webs\burracovelletriit\web.config Line: 95

Version Information: Microsoft .NET Framework Version:2.0.50727.3625; ASP.NET Version:2.0.50727.3618



c'è qualche errore nel copiare i file nel root? l'host win va bene? c'è qualche operazione preliminare che dovrei fare e che non ho fatto?
Grazie, Marty
Guido Eugenio
male
jenkaitalii@hotmail.com
Theo

Rispondo al quesito poiché individuare la causa dell'errore in questo caso è semplice; sia dal titolo dello stesso: "Parser Error Message: Unrecognized attribute targetFramework", sia ad un certo punto del testo in cui dice: "..Version Information: Microsoft .NET Framework Version:2.0.50727.3625.."

CMS ASP.NET necessita del Framework Versione 4 o superiore.

Immagino che aruba metta a disposizione degli utenti un pannello di controllo, cPanel o Plesk od altro, dal quale potrai cambiare la versione del Framework, giacché il problema nasce dal fatto che attualmente il server sta utilizzando la versione 2.0 e che questa però è incompatibile con il CMS.
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Confermo: Devi impostare per il tuo servizio di hosting, il Framework 4.0