.net CMS
.net CMS > Web Site Maker > Installazione e avvio dell’applicativo web > Problemi inerenti l’installazione del CMS

Se non vengono caricati i plugin

RSS
Autore
Giorno e Ora
Messaggio Operazioni
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Ieri con theo abbiamo scoperto quanto segue:
Se l'applicativo non viene settato per girare in modalità debub, non si caricano i plugin.

La modalità debubg è uno dei parametri di compilazione nel file web.config.

Spiegazione:

Evidentemente se la compilazione avviene in modalità debug si crea un unico assembly (eseguibile) che contiene applicativo e plugin, in caso contrario i plugin si compilano a parte.
Se i plugin rimangono nello stesso assembly, il programma madre non ha problemi ad accedervi e quindi na lanciarli in esecuzione.
Nel caso in cui i plugin si compilano in file esterni,l'applicativo madre non riesce a lanciarli in esecuzione per questioni di security policy, ovvero dato che le parti dell'applicazione si compilano in una directory tmp in cui l'applicativo non ha accesso, rimane impossibile mandarle in esecuzione.

Rimedio:
L'unico è quello di lasiare che l'applicativo giri in modalità debug.
Sono al vaglio altre ipotesi.
Guido Eugenio
male
jenkaitalii@hotmail.com
Theo

Ho provato a farlo ricompilare con i Plugins spostati nella directory app_code ma non cambia nulla. Bisognerebbe però anche capire se questa cosa può dipendere dal servizio host; il mio, soprannominato bronco, è assolutamente non performante, ci sono momenti in cui mettendo off l'applicazione dal pannello del Plesk da "IIS Application Pool" il sito resta online per diverso tempo, anche per più di 10 minuti.. Alla prova del benchmark il miglior risultato che riesco a leggere è 270, ma in certi momenti è al collasso con risultati sotto a 100, più volte ho letto 47! Il mio Asus Eee Pc-900 fa di meglio, alla stessa prova fornisce poco meno di mille e, quando a batteria, circa 300.
Andrea Bruno
male
customercare@officialguide.info
Webmaster

Ti hanno messo il sito su un computer che gira con la manovella.
Guido Eugenio
male
jenkaitalii@hotmail.com
Theo

Si. Praticamente l'aver coniato il termine "bronco" per indicare il tipo di web server nel quale sono capitato è corretto. smile_teeth